Anonymous Login
2018-12-16 10:15 UTC

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0000814OpenClonkObjectspublic2017-12-22 19:55
ReporterAndriel 
Assigned To 
PrioritynormalSeverityminorReproducibilityalways
StatusconfirmedResolutionreopened 
PlatformComputerOSWindowsOS Version7 64bit
Product Version 
Target Versiongit masterFixed in Version 
Summary0000814: Dig + landscape border = fly
DescriptionWhen you are at the left or right border and dig upwards, the clonk is "flying".
Only works in front of "Tunnel" material. If you get to the "Sky" background, the clonk falls down.
Steps To Reproduce1.Start "Gold rush" (Or any other scenario where you have a shovel and earth)
2.Go to the left/right border of the map
3.Dig straight down
4.If you are a bit deep in the ground, point upwards (and towards the border) with your mouse and dig (so dig upwards)
5.You fly
6.See what happens if you get to the sky.
TagsNo tags attached.
Attached Files
  • png file icon Screenshot004.png (Attachment missing)

-Relationships
related to 0000946closedClonkonaut Lorries fall out of landscape 
related to 0001652resolvedLuchs Climbing on the landscape border 
+Relationships

-Notes

~0002203

Isilkor (developer)

Also works when scaling as long as you leave a one-pixel strip right at the border and start your scale there.

~0002204

Isilkor (developer)

We've decided that this is acceptable behavior and will be extending it to allow you to scale the "closed" part of the landscape border (below the horizon). This is because conceptually, in a map with AutoScanSideOpen, the landscape extends infinitely beyond the borders. Of course you can't change it, because it doesn't really exist, but since it's there in concept you should be able to interact with it as much as possible.

~0002206

Isilkor (developer)

You can now scale the landscape border up to the horizon, starting from revision e95896c3109a.

~0002557

Isilkor (developer)

Reopened due to IRC request.

~0002558

Kobra (reporter)

I feel like while the abbility to climb up borders is intended, the way how it is possible to dig straight up is odd. It is not possible at other places beside the borders. Also, it really looks like the clonk is flying. Digging up at the border should work like at every other location.

~0002559

Sven2 (developer)

The problem here is of course that the Clonk is pushed into the landscape by its BorderBound, so he cannot get close enough to the border for digging to look "normal".

Making it possible to define a maximum border distance would also help fix 0000946 by the way.

~0004234

Isilkor (developer)

Moving this to 8.0 because it is purely cosmetic.
+Notes

-Issue History
Date Modified Username Field Change
2012-10-10 18:01 Andriel New Issue
2012-10-10 20:14 Isilkor Assigned To => Isilkor
2012-10-10 20:14 Isilkor Status new => confirmed
2012-10-10 21:12 Isilkor Note Added: 0002203
2012-10-11 11:13 Isilkor Note Added: 0002204
2012-10-13 10:15 Isilkor Note Added: 0002206
2012-10-13 10:15 Isilkor Status confirmed => resolved
2012-10-13 10:15 Isilkor Resolution open => fixed
2013-03-30 14:32 Isilkor Note Added: 0002557
2013-03-30 14:32 Isilkor Assigned To Isilkor =>
2013-03-30 14:32 Isilkor Status resolved => feedback
2013-03-30 14:32 Isilkor Resolution fixed => reopened
2013-03-30 14:34 Kobra File Added: Screenshot004.png
2013-03-30 14:36 Kobra Note Added: 0002558
2013-03-30 14:47 Sven2 Note Added: 0002559
2013-11-05 18:26 Newton Status feedback => new
2013-11-05 18:28 Newton Relationship added related to 0000946
2015-10-16 00:33 Sven2 Target Version => 7.0
2015-11-30 12:12 Clonkonaut Status new => confirmed
2015-12-02 15:00 Isilkor Note Added: 0004234
2015-12-02 15:00 Isilkor Target Version 7.0 => 8.0
2016-02-01 00:43 Isilkor Relationship added related to 0001652
2017-12-22 19:55 Luchs Target Version 8.0 => git master
+Issue History