Anonymous Login
2019-09-22 04:36 UTC

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0000007OpenClonkEnginepublic2013-11-06 11:46
ReporterMrBeast 
Assigned ToIsilkor 
PrioritylowSeveritytweakReproducibilityhave not tried
StatusclosedResolutionfixed 
Product Version 
Target VersionFixed in Version 
Summary0000007: CMakefile: some Redefinitions
DescriptionThe CMakefile-Generation creates some multiple #defines of the same name.

(HAVE_ICONV, HAVE_SYS_TYPES_H, HAVE_STDINT_H and HAVE_SIGNAL_H)

It is no error but the warnings are annoying.
Additional Information/usr/include/SDL/SDL_config.h:64:1: warning: "HAVE_SYS_TYPES_H" redefined
In file included from /home/manuel/openclonk/standard/inc/Standard.h:24,
                 from /home/manuel/openclonk/engine/inc/C4Include.h:84,
                 from /home/manuel/openclonk/engine/src/C4WinMain.cpp:20:
/home/manuel/openclonk/config.h:98:1: warning: this is the location of the previous definition
In file included from /usr/include/SDL/SDL_stdinc.h:28,
                 from /usr/include/SDL/SDL_types.h:24,
                 from /usr/include/SDL/SDL_mixer.h:28,
                 from /home/manuel/openclonk/engine/inc/C4SoundSystem.h:30,
                 from /home/manuel/openclonk/engine/inc/C4Application.h:24,
                 from /home/manuel/openclonk/engine/src/C4WinMain.cpp:21:
/usr/include/SDL/SDL_config.h:74:1: warning: "HAVE_STDINT_H" redefined
In file included from /home/manuel/openclonk/standard/inc/Standard.h:24,
                 from /home/manuel/openclonk/engine/inc/C4Include.h:84,
                 from /home/manuel/openclonk/engine/src/C4WinMain.cpp:20:
/home/manuel/openclonk/config.h:71:1: warning: this is the location of the previous definition
In file included from /usr/include/SDL/SDL_stdinc.h:28,
                 from /usr/include/SDL/SDL_types.h:24,
                 from /usr/include/SDL/SDL_mixer.h:28,
                 from /home/manuel/openclonk/engine/inc/C4SoundSystem.h:30,
                 from /home/manuel/openclonk/engine/inc/C4Application.h:24,
                 from /home/manuel/openclonk/engine/src/C4WinMain.cpp:21:
/usr/include/SDL/SDL_config.h:78:1: warning: "HAVE_SIGNAL_H" redefined
In file included from /home/manuel/openclonk/standard/inc/Standard.h:24,
                 from /home/manuel/openclonk/engine/inc/C4Include.h:84,
                 from /home/manuel/openclonk/engine/src/C4WinMain.cpp:20:
/home/manuel/openclonk/config.h:68:1: warning: this is the location of the previous definition
In file included from /usr/include/SDL/SDL_stdinc.h:28,
                 from /usr/include/SDL/SDL_types.h:24,
                 from /usr/include/SDL/SDL_mixer.h:28,
                 from /home/manuel/openclonk/engine/inc/C4SoundSystem.h:30,
                 from /home/manuel/openclonk/engine/inc/C4Application.h:24,
                 from /home/manuel/openclonk/engine/src/C4WinMain.cpp:21:
/usr/include/SDL/SDL_config.h:133:1: warning: "HAVE_ICONV" redefined
In file included from /home/manuel/openclonk/standard/inc/Standard.h:24,
                 from /home/manuel/openclonk/engine/inc/C4Include.h:84,
                 from /home/manuel/openclonk/engine/src/C4WinMain.cpp:20:
/home/manuel/openclonk/config.h:17:1: warning: this is the location of the previous definition
TagsNo tags attached.
Attached Files

-Relationships
+Relationships

-Notes

~0000033

Isilkor (developer)

SDL shouldn't pollute application namespace with those macros. We can workaround this issue by using different identifiers for these.
Changing this to low priority since the issue lies with SDL in my opinion.

~0000091

Günther (developer)

The problem is that CMake uses empty defines for these (#define HAVE_ICONV), instead of the 1 SDL and autoconf use (#define HAVE_ICONV 1). I've changed the engine to not rely on this during the initial CMake conversion, but I'm not going to spent any more time fighting CMake for this.

~0000092

MrBeast (reporter)

Have uploaded a fix for the problem now. It is very easy: just put a 1 at the end of the defines.

~0000093

Isilkor (developer)

Thanks, I've pushed that patch to the main branch.
+Notes

-Issue History
Date Modified Username Field Change
2009-05-31 15:51 MrBeast New Issue
2009-06-02 21:14 Anonymous Note Added: 0000010
2009-06-11 17:39 Anonymous Note Added: 0000014
2009-06-12 14:18 Isilkor Note Deleted: 0000014
2009-06-17 15:39 Anonymous Note Added: 0000021
2009-06-17 19:30 Anonymous Note Deleted: 0000021
2009-06-17 22:33 Anonymous Note Added: 0000023
2009-06-18 02:12 Anonymous Note Added: 0000025
2009-06-18 09:51 Anonymous Note Added: 0000027
2009-06-19 21:16 Anonymous Note Deleted: 0000023
2009-06-19 21:16 Anonymous Note Deleted: 0000025
2009-06-19 21:17 Anonymous Note Deleted: 0000027
2009-06-23 07:21 Anonymous Note Edited: 0000010
2009-06-25 13:13 Anonymous Note Edited: 0000010
2009-06-25 19:41 Clonkonaut Note Deleted: 0000010
2009-06-29 03:39 Isilkor Note Added: 0000033
2009-06-29 03:39 Isilkor Priority normal => low
2009-08-05 20:49 Günther Note Added: 0000091
2009-08-09 11:42 MrBeast File Added: config.h.cmake
2009-08-09 11:45 MrBeast Note Added: 0000092
2009-08-09 12:08 MrBeast File Added: patch
2009-08-09 12:48 Isilkor Status new => resolved
2009-08-09 12:48 Isilkor Resolution open => fixed
2009-08-09 12:48 Isilkor Assigned To => Isilkor
2009-08-09 12:48 Isilkor Note Added: 0000093
2009-12-25 19:08 Isilkor Status resolved => closed
2013-11-06 11:46 Newton Fixed in Version => 1.0
2014-02-17 03:32 Newton File Deleted: config.h.cmake
2014-02-17 03:32 Newton File Deleted: patch
+Issue History