Anonymous Login
2021-10-24 18:04 UTC

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0000518OpenClonkEngine - Renderingpublic2013-11-06 16:50
ReporterLuchs 
Assigned ToClonk-Karl 
PrioritynormalSeverityfeatureReproducibilityN/A
StatusclosedResolutionfixed 
Product Version 
Target VersionFixed in Version 
Summary0000518: Antialiasing
DescriptionThere should be an option for enabling antialiasing in-game, as not everyone wants to tweak that in his driver's settings.
Also I think antialiasing should be enabled by default.
TagsNo tags attached.
Attached Files

-Relationships
+Relationships

-Notes

~0001427

Newton (administrator)

I wonder, if it is just a switch in the graphics driver options, it's perhaps also just a switch in OpenGL?

Any knowledge about that?

~0001434

Clonk-Karl (administrator)

From what I have seen so far when I investigated this a bit it seems that we need to use platform specific API (that is, WGL or GLX) to request multisampling (FSAA).

~0001481

Clonk-Karl (administrator)

If we want to do this properly then we will need to re-create the OpenGL context when changing AA settings in the graphics menu, which is not so straight-forward since this also requires to reload all textures, VBOs, etc.

It should be rather easy though to add an option which requires restarting the engine to take effect. I guess I'll start with this and then see how much work recreating the context really is. Maybe the latter also helps against oddities with resolution change on Windows, by the way.

Someone else will have to write the Windows/WGL code though.

~0001486

Clonk-Karl (administrator)

Implemented. I even did the Windows code.
+Notes

-Issue History
Date Modified Username Field Change
2010-12-05 12:41 Luchs New Issue
2010-12-05 14:32 Clonk-Karl Assigned To => Clonk-Karl
2010-12-05 14:32 Clonk-Karl Status new => acknowledged
2010-12-15 15:35 Newton Note Added: 0001427
2010-12-15 22:38 Clonk-Karl Note Added: 0001434
2010-12-25 22:28 Clonk-Karl Status acknowledged => assigned
2010-12-25 22:28 Clonk-Karl Note Added: 0001481
2010-12-29 14:22 Clonk-Karl Note Added: 0001486
2010-12-29 14:22 Clonk-Karl Status assigned => resolved
2010-12-29 14:22 Clonk-Karl Resolution open => fixed
2013-11-06 12:48 Newton Fixed in Version => 2.0
2013-11-06 16:50 Newton Status resolved => closed
+Issue History