Anonymous Login
2019-05-26 13:08 UTC

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0000005OpenClonkEngine - Graphicspublic2013-11-07 05:54
ReporterAnonymous 
Assigned ToNewton 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionunable to reproduce 
Product Version 
Target VersionFixed in Version 
Summary0000005: Zooming FOW
DescriptionThe FOW is not zoomed. You can reproduce this bug when zooming out a far distance.
TagsNo tags attached.
Attached Files

-Relationships
+Relationships

-Notes

~0000048

Marky (developer)

Last edited: 2009-07-09 09:58

Maybe restrict the zoom so that the scaling factor is never less than 1.0? As long as you zoom in (factor >= 1.0) there seem to be no problems with FoW

Update: I tested this on my engine and it works just fine. Is there any need to to scale the view less than 1.0? On small resolutions when you zoom out you won't see very much anyway

~0000071

Ape (reporter)

There are some differences on the FoW when you compare the zoom levels 1x and for example 4x. So just limiting the zoom level is not the solution, I think.

~0000089

Günther (developer)

The FoW should just be calculated correctly. That it doesn't get more detailed when one zooms out is an optimization, though.
+Notes

-Issue History
Date Modified Username Field Change
2009-05-11 14:46 Anonymous New Issue
2009-07-06 14:16 Marky Note Added: 0000048
2009-07-09 09:58 Marky Note Edited: 0000048
2009-07-17 18:55 Ape Note Added: 0000071
2009-08-05 20:40 Günther Note Added: 0000089
2010-01-19 01:14 Newton Status new => resolved
2010-01-19 01:14 Newton Resolution open => unable to reproduce
2010-01-19 01:14 Newton Assigned To => Newton
2010-01-24 13:55 Newton Category Engine => Engine - Graphics
2013-11-07 05:54 Newton Status resolved => closed
+Issue History