Anonymous Login
2019-11-14 09:09 UTC

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0000003OpenClonkEnginepublic2013-11-06 10:00
ReporterNewton 
Assigned ToGünther 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
Product Version 
Target VersionFixed in Version 
Summary0000003: Linux: WM believes OC is hung
DescriptionWhile I am doing nothing in the menu system or while I am playing regularly, Ubuntu thinks Clonk hang up (the screen turns grey). But actually, everything works - mouse & keyboard input are accepted.
Additional InformationWhile in the menu system, one has to change the menu screen to another screen to "turn the window colorful again". During the game, it happens sometimes.
TagsNo tags attached.
Attached Files

-Relationships
+Relationships

-Notes

~0000011

Anonymous (viewer)

I thought I had implemented the "ping" protocol correctly, but I only tested by confirming that metacity offers to kill Clonk when trying to close it. Does this bug still occur if you make Clonk not opt into the protocoll? http://standards.freedesktop.org/wm-spec/wm-spec-latest.html#id2552442

~0000068

Ape (reporter)

This doesn't happen with Metacity, but when I enable Compiz (which checks that the windows response), it randomly flashes grayscale for less than a second and then gets the colours back. Maybe the game replies ping with a delay or something.

~0000097

Newton (administrator)

Actually it replies correctly to the ping but in my tests the ping wasn't even sent. Perhaps there is another signal the application has to respond to (since a certain WM version or in general?).

~0000113

Newton (administrator)

Was the same bug as 0000040

~0000115

Isilkor (developer)

No, it wasn't; 0000040 was strictly Windows-only.

~0000116

Newton (administrator)

when I last tested it, the "grey screen" didn't appear again.

~0000117

Newton (administrator)

No, I was wrong. It happened again.

~0000124

Günther (developer)

The ping reply sometimes got stuck in the XLib buffer, so there was some amount of luck involved, because sometimes the buffer got full and flushed before the window manager gave up waiting.
+Notes

-Issue History
Date Modified Username Field Change
2009-05-09 23:31 Newton New Issue
2009-05-09 23:31 Newton File Added: Pantallazo1.jpg
2009-05-10 14:06 Anonymous Note Added: 0000003
2009-06-02 21:22 Anonymous Note Added: 0000011
2009-06-11 17:38 Anonymous Note Added: 0000013
2009-06-12 14:18 Isilkor Note Deleted: 0000013
2009-06-17 15:02 Anonymous Note Added: 0000020
2009-06-17 20:42 Anonymous Note Added: 0000022
2009-06-18 00:01 Anonymous Note Added: 0000024
2009-06-18 07:42 Anonymous Note Added: 0000026
2009-06-18 11:53 Anonymous Note Added: 0000028
2009-06-25 19:39 Clonkonaut Note Added: 0000032
2009-06-25 19:40 Clonkonaut Note Deleted: 0000020
2009-06-25 19:40 Clonkonaut Note Deleted: 0000022
2009-06-25 19:40 Clonkonaut Note Deleted: 0000024
2009-06-25 19:40 Clonkonaut Note Deleted: 0000026
2009-06-25 19:40 Clonkonaut Note Deleted: 0000028
2009-06-25 19:41 Clonkonaut Note Edited: 0000032
2009-06-29 03:22 Isilkor Note Deleted: 0000032
2009-07-16 11:40 Ape Note Added: 0000068
2009-08-26 20:49 Newton Note Added: 0000097
2009-08-28 15:53 Anonymous Note Deleted: 0000003
2009-10-10 20:40 Newton Relationship added related to 0000040
2009-10-13 23:45 Isilkor Relationship deleted related to 0000040
2009-10-14 10:56 Newton Note Added: 0000113
2009-10-14 10:56 Newton Status new => resolved
2009-10-14 10:56 Newton Resolution open => duplicate
2009-10-14 10:56 Newton Assigned To => Newton
2009-10-14 14:15 Isilkor Assigned To Newton =>
2009-10-14 14:15 Isilkor Note Added: 0000115
2009-10-14 14:15 Isilkor Status resolved => feedback
2009-10-14 14:15 Isilkor Resolution duplicate => reopened
2009-10-14 14:15 Isilkor Status feedback => acknowledged
2009-10-14 17:51 Newton Note Added: 0000116
2009-10-14 17:54 Newton Note Added: 0000117
2009-10-14 18:51 Isilkor Summary No response => Linux: WM believes OC is hung
2009-10-22 20:49 Günther Note Added: 0000124
2009-10-22 20:49 Günther Status acknowledged => resolved
2009-10-22 20:49 Günther Fixed in Version => 4.0
2009-10-22 20:49 Günther Resolution reopened => fixed
2009-10-22 20:49 Günther Assigned To => Günther
2009-12-25 19:08 Isilkor Status resolved => closed
2013-11-06 09:53 Newton File Deleted: Pantallazo1.jpg
2013-11-06 09:54 Newton Fixed in Version 4.0 => 1.0
+Issue History