Anonymous Login
2019-11-22 07:56 UTC

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0000019OpenClonkEnginepublic2009-10-14 23:12
ReporterMarky 
Assigned ToIsilkor 
PrioritynormalSeveritytextReproducibilityalways
StatusclosedResolutionunable to reproduce 
Product Version 
Target VersionFixed in Version 
Summary0000019: No umlauts/mutated vowels
DescriptionInstead of an umlaut there are question marks in the text
Additional InformationCompiled on System:
- Windows XP
- VC9
- Platform SDK for Windows Server 2003 R
TagsNo tags attached.
Attached Files

-Relationships
+Relationships

-Notes

~0000043

Isilkor (developer)

Not seeing this; are you using a recent source?

~0000044

Marky (developer)

Last edited: 2009-07-05 20:15

Source is revision f54c399c2b5d; Compiled successful for the first time today. CMAKE_USE_PTHREADS_INIT set to false in CMake because an unassigned value gave me errors and it is WIN32 anyway.

Update: screenshot uploaded. In some cases not only the mutated vowel is replaced by a question mark, but the following letter as well. See screenshot "Stärke"->"St?ke"

~0000046

Isilkor (developer)

You seem to be using an old (as in non-UTF8) LanguageDE.txt. Please make sure you're using the most recent one. MD5 of the file should be 17323fa5cfb02c7c55d7825672d09873.

~0000047

Marky (developer)

I took the LanguageDE.txt from Carlis package, now it works. How can I get any of the recent files? So far I can access the source code only

~0000049

Isilkor (developer)

All game content is contained in the source repository in the directory "planet". See http://forum.openclonk.org/topic_show.pl?tid=91 to access the repository.
+Notes

-Issue History
Date Modified Username Field Change
2009-07-05 18:40 Marky New Issue
2009-07-05 20:06 Isilkor Note Added: 0000043
2009-07-05 20:11 Marky Note Added: 0000044
2009-07-05 20:14 Marky File Added: umlaut.jpg
2009-07-05 20:15 Marky Note Edited: 0000044
2009-07-06 02:35 Isilkor Note Added: 0000046
2009-07-06 14:09 Marky Note Added: 0000047
2009-07-06 23:56 Isilkor Note Added: 0000049
2009-07-06 23:56 Isilkor Status new => resolved
2009-07-06 23:56 Isilkor Resolution open => unable to reproduce
2009-07-06 23:56 Isilkor Assigned To => Isilkor
2009-10-14 23:12 Isilkor Status resolved => closed
2013-11-06 11:17 Newton File Deleted: umlaut.jpg
+Issue History