Anonymous Login
2020-08-10 18:42 UTC

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0001710OpenClonkObjectspublic2016-12-25 18:28
ReporterMupf 
Assigned ToMarky 
PrioritynormalSeverityminorReproducibilitysometimes
StatusresolvedResolutionfixed 
Product Version 
Target VersionFixed in Version 
Summary0001710: Scaling with wrong animation
DescriptionSometimes, especially when jumping from a wall to a close rope ladder (see screenshot), the clonk has the wrong animation when scaling. (I think it's falling?).
I experienced this without the ladder once, but could only reproduce with one.
Steps To Reproduce1. Create the situation as shown in the screenshot (taken in "Finsterschloss")
2. Scale up the wall
3. Jump to the left onto the rope ladder
4. Scale
Additional InformationThe screenshots look like I'm just falling down near the wall. Thats not the case, I was able to scale up and down with the wrong animation but had no recording option.
TagsNo tags attached.
Attached Files

-Relationships
+Relationships

-Notes

~0005130

Clonkonaut (developer)

Should be fixed.

~0005546

Marky (developer)

Bug still happens, found the cause probably. When the bug appears the Clonk has the "JumpWall.L" or "JumpWall.R" animation in the movement slot.
This leads me to think that the WallJump-effect is not terminated correctly, and thus the animation will be played again when StartJump() gets called.

~0005554

Marky (developer)

The effects are terminated correctly, just in the wrong order. With logging added I found out:

Start jump at frame 413
Grabbed ladder at frame 413
Animation before climb: 5
Animation after climb: 1
Grabbed ladder finish
Animation before wall jump: 1
Animation after wall jump: 3
Finished wall jump

So it seems that the grabbing the ladder is called before the jump start call is even finished. What could cause this?

~0005560

occ (reporter)

Hi! There's been a check-in that references this bug. For more information you can visit the repository browser at this address:
https://git.openclonk.org/openclonk.git/commitdiff/17d6bb0e1b159c4ec5452c71f60cc542566a2092

Changeset 17d6bb0 by Mark <markh4b@hotmail.com>
0001710: Logs for debugging

~0005561

occ (reporter)

Hi! There's been a check-in that references this bug. For more information you can visit the repository browser at this address:
https://git.openclonk.org/openclonk.git/commitdiff/45f98ce03a142afa51da9782e884247c16af75d2

Changeset 45f98ce by Mark <markh4b@hotmail.com>
0001710: Fix the bug

The problem was that the call to Actmap.*.StartCallLadderOverloaded happend parallely with the ladder search effect and finished after the search effect call was finished, starting a wall jump animation after the Clonk grabbed the ladder.

~0005562

occ (reporter)

Hi! There's been a check-in that references this bug. For more information you can visit the repository browser at this address:
https://git.openclonk.org/openclonk.git/commitdiff/bace3b7d2bb304b17b70ede4c734cb3975336ce6

Changeset bace3b7 by Mark <markh4b@hotmail.com>
0001710: Remove logs for debugging

~0005563

occ (reporter)

Hi! There's been a check-in that references this bug. For more information you can visit the repository browser at this address:
https://git.openclonk.org/openclonk.git/commitdiff/7c2a4ee574391fe2c4a6f43885484db8dc23be14

Changeset 7c2a4ee by Mark <markh4b@hotmail.com>
0001710: Fix wrong animation on ladder after wall jump

The problem was that the call to Actmap.*.StartCallLadderOverloaded happend parallely with the ladder search effect and finished after the search effect call was finished, starting a wall jump animation after the Clonk grabbed the ladder.

~0005564

Marky (developer)

Solved this by calling the ladder search effect one frame later.
+Notes

-Issue History
Date Modified Username Field Change
2016-04-04 17:31 Mupf New Issue
2016-04-04 17:31 Mupf File Added: Screenshot009.png
2016-06-18 22:27 Clonkonaut Note Added: 0005130
2016-06-18 22:27 Clonkonaut Status new => resolved
2016-06-18 22:27 Clonkonaut Resolution open => fixed
2016-06-18 22:27 Clonkonaut Assigned To => Clonkonaut
2016-12-18 17:22 Marky Assigned To Clonkonaut => Marky
2016-12-18 17:22 Marky Status resolved => assigned
2016-12-18 17:22 Marky Note Added: 0005546
2016-12-20 09:57 Marky Note Added: 0005554
2016-12-25 18:24 occ Note Added: 0005560
2016-12-25 18:24 occ Note Added: 0005561
2016-12-25 18:24 occ Note Added: 0005562
2016-12-25 18:24 occ Note Added: 0005563
2016-12-25 18:28 Marky Status assigned => resolved
2016-12-25 18:28 Marky Note Added: 0005564
+Issue History