Anonymous Login
2018-12-16 10:15 UTC

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0001505OpenClonkObjectspublic2018-01-07 18:02
Reporterala 
Assigned ToClonkonaut 
PrioritynormalSeverityminorReproducibilityalways
StatusfeedbackResolutionno change required 
Product Version 
Target Version9.0Fixed in Version 
Summary0001505: You can use the teleglove to cheat through fog of war
DescriptionThe sparks of the teleglove illuminate the surroundings, this is cool - but works regardless of materials and therefor you can scan the landscape with it. It should only work on non-solid materials. Also it should respect line of sight, so you wouln't be able to discover an underground cave with it.
TagsNo tags attached.
Attached Files

-Relationships
+Relationships

-Notes

~0004352

Zapper (developer)

In treasure hunt it's really useful (and necessary?) because otherwise the mission would be basically impossible or at least a lot more frustrating..

But yeah, it's pretty hacky otherwise.

~0004354

Sven2 (developer)

It's a nice secondary use. We also have the fixed viewport to limit view range. Does it really need to be changed?

~0004356

Zapper (developer)

Imo not now as we don't have any scenarios where this is an issue. We should have it on the radar, though.

~0004357

ala (developer)

Last edited: 2015-12-21 17:55

View 2 revisions

Yes, I agree it was useful in that mission - and this can wait till we have more light sources (which is at least scheduled in the milestone - who knows when its done).

Still for a teammelee the behaviour would be unwanted.

~0004358

Sven2 (developer)

Why unwanted? It's a scouting tool. And it's not that easy to build (doesn't it need cloth?)

~0004360

Clonkonaut (developer)

It doesn't need cloth, no. It needs "Crystal" something we don't have. ;)
But it is built in the Inventor's Workshop and therefore a high tier product. It's okay for it to be powerful.

I would agree that this doesn't need change. It's a very nice use for this tool.

~0004361

Sven2 (developer)

So, how about we add the scouting use to the description and close the bug? If it turns out to be problematic in a future scenario, we can think about restrictions.

~0004363

ala (developer)

Good argument with the high tier product. It probably won't interfere with other light sources normally. Ok, I'm fine with keeping it as well.

Before the bug is closed:
Could the need of crystal be changed to diamonds or gemstones? That would still make it hard to produce in most cases.

~0004364

Clonkonaut (developer)

Diamonds is a good idea.

~0004365

Maikel (developer)

I would think gem stones would be good yes, it is very powerful. But then we need to check all rounds which use the TeleGlove whether they have gems.

Diamonds would be a bad idea, since no round uses them and they have not been tested. I would keep diamonds a bit more special and rather not use them as resources for the main items in the game.

~0004366

Clonkonaut (developer)

Done.

~0004367

Maikel (developer)

Last edited: 2015-12-22 10:59

View 2 revisions

You did the opposite of what I preferred... and just broke almost all our scenarios with the teleglove.

~0004368

Clonkonaut (developer)

Last edited: 2015-12-22 11:02

View 2 revisions

Huh @every round needs testing
Up until now, it was impossible to make a teleglove because there is no object "Crystal". How could any scenario rely on telegloves being producable then?

We can change this to gemstones, however, I suggest to wait for this:
http://bugs.openclonk.org/view.php?id=1148

Otherwise you'd have to (arbitrarily) decide which of the two gems you need.

I don't see the teleglove as being a "main item" though but a very special one. It solves so many problems and makes so many things easier, I'd be okay with it being hard to get.

~0004369

Clonkonaut (developer)

I see. Definitions that did not exist are ignored by the production menu? So, the teleglove could be made with just 2 metal then?

Well, I had a quick look. Four scenarios list the teleglove in knowledge (Acid Drilling, Deadly Grotto, Deep Sea Mining, Golden Mountain), two supply it via script (Flooded Veins and Gem Grabbers). Of those only two have an inventor's lab (Golden Mountain and Gem Grabbers). I don't know if there is ruby / amethyst anywhere in Golden Mountain.

Diamonds are easily added to those scenarios, gemstones are not.

I am open for suggestions.

~0004370

Clonkonaut (developer)

I forgot Krakatoa which also provides the knowledge via script. No gemstones there either.

~0004371

Pyrit (developer)

I'd suggest to make it rely on electric power, so you can only x-ray the the ground near your base.

~0004372

Sven2 (developer)

Last edited: 2015-12-22 12:22

View 2 revisions

Golden Mountain has rubies and building a tele glove is the standard strategy there. If it requires diamonds then diamonds have to be added to that round (I suggest putting at least some of them into the left area of the landscape).

In Gem Grabbers we also often built tele gloves. Gem grabbers also has gems but no diamonds (yet).

Yes unknown definitions in requirements are ignored.

~0004373

Clonkonaut (developer)

I don't have the time to add the diamonds to all those scenarios now. I reverted the component change.
You can again build the teleglove from 2 metal.

I still strongly favour the diamond idea though.

~0004374

Maikel (developer)

I strongly disfavour the diamond idea, it adds another layer of complexity to the game which is not obvious to players, is not existing in any rounds we currently have and has not been tested. This means it will break all existing rounds and especially means I have to redesign all rounds.

Before we go ahead with these I need to be convinced. What is the gameplay argument behind diamonds?

Also Gem Grabbers will not get diamonds, because it is about gems.

I think I'd even prefer a solution which is just more metal, and maybe require a gold bar to produce it, it is already yellow and shines, after all.

~0004375

Maikel (developer)

Power is also a solution, but then it needs to be able to store a bit of charge so that you can use it briefly outside of the base. Otherwise it is useless.

~0004387

Clonkonaut (developer)

Well, I don't care that much about the teleglove.
The whole item just always felt a bit like a cheat object or game solver to me ;) Just not something a determined player should get in the first 15 minutes of playing.
Therefore, diamonds offer a nice gameplay mechanic because you can't simply get them but discover those over time like a hidden treasure. At some point, you will eventually have them to craft some "uber items"! It's like a little random spawn.
As for Gem Grabbers I don't see a problem with the scenario being about "gemstones" because that includes diamonds ;)
But also can you manage just fine without a teleglove as we did in our video playthrough. I wouldn't say the scenario is broken without the glove.

I agree that diamonds need proper testing and some scenarios will have to be changed. That's why we shouldn't change stuff for the upcoming release. I did that because I wrongfully thought the teleglove isn't craftable anyway.
But you might consider the idea for 8.0. I find those secret, hidden, powerful objects intriguing

~0004388

Maikel (developer)

Okay, let's postpone this until 8.0.

~0004511

Maikel (developer)

After a discussion I propose that it can be build from either diamond, ruby or amethyst + 2x metal.

~0005868

occ (reporter)

Hi! There's been a check-in that references this bug. For more information you can visit the repository browser at this address:
https://git.openclonk.org/openclonk.git/commitdiff/2c4aba74f0699e558f381a965637b33abd7189d0

Changeset 2c4aba7 by Clonkonaut <Armag3ddon@web.de>
Teleglove production: needs any one gem (diamond, ruby, amethyst) to produce (as discussed in 0001505).

~0005870

Clonkonaut (developer)

As you can see, I changed the teleglove as discussed. Needs testing and can be removed very easily (remove the one function from the teleglove's script).
+Notes

-Issue History
Date Modified Username Field Change
2015-12-19 22:39 ala New Issue
2015-12-21 11:45 Zapper Note Added: 0004352
2015-12-21 16:01 Sven2 Note Added: 0004354
2015-12-21 17:43 Zapper Note Added: 0004356
2015-12-21 17:55 ala Note Added: 0004357
2015-12-21 17:55 ala Note Edited: 0004357 View Revisions
2015-12-21 18:42 Sven2 Note Added: 0004358
2015-12-21 23:17 Clonkonaut Note Added: 0004360
2015-12-22 02:35 Sven2 Note Added: 0004361
2015-12-22 09:14 ala Note Added: 0004363
2015-12-22 10:44 Clonkonaut Note Added: 0004364
2015-12-22 10:45 Maikel Note Added: 0004365
2015-12-22 10:54 Clonkonaut Note Added: 0004366
2015-12-22 10:54 Clonkonaut Status new => closed
2015-12-22 10:54 Clonkonaut Assigned To => Clonkonaut
2015-12-22 10:54 Clonkonaut Resolution open => no change required
2015-12-22 10:58 Maikel Note Added: 0004367
2015-12-22 10:58 Maikel Status closed => new
2015-12-22 10:59 Maikel Note Edited: 0004367 View Revisions
2015-12-22 10:59 Clonkonaut Note Added: 0004368
2015-12-22 11:02 Clonkonaut Note Edited: 0004368 View Revisions
2015-12-22 11:16 Clonkonaut Note Added: 0004369
2015-12-22 11:22 Clonkonaut Note Added: 0004370
2015-12-22 12:20 Pyrit Note Added: 0004371
2015-12-22 12:21 Sven2 Note Added: 0004372
2015-12-22 12:22 Sven2 Note Edited: 0004372 View Revisions
2015-12-22 12:49 Clonkonaut Note Added: 0004373
2015-12-22 15:43 Maikel Note Added: 0004374
2015-12-22 15:48 Maikel Note Added: 0004375
2015-12-25 12:02 Clonkonaut Note Added: 0004387
2015-12-25 20:45 Maikel Note Added: 0004388
2015-12-25 20:45 Maikel Assigned To Clonkonaut =>
2015-12-25 20:45 Maikel Status new => acknowledged
2015-12-25 20:45 Maikel Product Version 7.0 => 8.0
2016-01-04 15:18 Maikel Product Version 8.0 =>
2016-01-04 15:18 Maikel Target Version => 8.0
2016-01-10 09:30 Maikel Note Added: 0004511
2017-10-27 11:26 occ Note Added: 0005868
2017-10-27 11:27 Clonkonaut Note Added: 0005870
2017-11-01 00:39 Clonkonaut Assigned To => Clonkonaut
2017-11-01 00:39 Clonkonaut Status acknowledged => feedback
2018-01-07 18:02 Clonkonaut Target Version 8.0 => 9.0
+Issue History