Anonymous Login
2019-11-21 00:55 UTC

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0001459OpenClonkGraphicspublic2016-06-28 09:21
Reporterkent_elyue 
Assigned ToIsilkor 
PrioritynormalSeverityminorReproducibilityalways
StatusresolvedResolutionfixed 
PlatformWindowsOSWindowsOS Versionwin8
Product Version 
Target VersionFixed in Version 
Summary0001459: character looks strange and gangly
DescriptionThe bug is in the graphics of the character. I'm not sure I can adequately describe it in words. I do have a screenshot of it. The character seems to present with bugged out eyes, and the neck and limbs are like really long rubber bands.

It's as though a dot-to-dot was drawn in the wrong order. It's as though the elbows are down below the knees or something, and the texture stretches from the shoulders way out to the elbows and then further again to the hands. It's weird. And yes, in the animation, when standing still, the character looks around and the white parts of the eyes get really long and bugged out, just like in some cartoons.

Perhaps it's a graphics card issue? We've got Intel Integrated Graphics Chips. Running win8 on a laptop. Sadly, 6.1 doesn't work at all on my linux mint system so I couldn't compare it. Version 6.0 plays and looks fine on all of my systems.
Steps To Reproducejust run the game.
TagsNo tags attached.
Attached Files

-Relationships
has duplicate 0001689resolvedIsilkor Models glitching. 
+Relationships

-Notes

~0004138

Maikel (developer)

Do you have the latest drivers on your Intel graphics chip? This may help, this bug is very similar to some already reported.

And please also try with a newer version here: http://www.openclonk.org/nightly-builds/

~0004140

kent_elyue (reporter)

Hi! Thanks for the reply!

I have a win8 64 bit system, but I tried both the 32 and 64 bit versions. I've tried the nightly builds a couple times.

openclonk-snapshot-20151119-d8ec703f82-win32-i386-mingw.zip
openclonk-snapshot-20151119-d8ec703f82-win32-amd64-mingw.zip
openclonk-snapshot-20151125-95285c6f9e-win32-i386-mingw.zip
openclonk-snapshot-20151125-95285c6f9e-win32-amd64-mingw.zip
openclonk-6.1.exe
openclonk-6.1-x64.exe

All of them exhibit the same glitch.

And yes, I double checked that the video drivers are up to date with the latest version.

~0004141

Sven2 (developer)

Can you upload an OpenClonk.log and the shader log file (from %APPDATA%\OpenClonk\) here?

~0004145

kent_elyue (reporter)

OpenClonk.log uploaded. I couldn't locate a shader log file anywhere. I looked in %APPDATA%\OpenClonk\ and in the installation folder. Is it somewhere else?

~0004146

Sven2 (developer)

Last edited: 2015-11-26 00:05

View 4 revisions

[17:50:53] GL 3.1.0 - Build 9.17.10.3040 on Intel(R) HD Graphics 3000 (Intel)

Where did you get your drivers from? I have an Optimus chip, but I might be able to downgrade to your driver version and use the Intel card to test if I get the same errors

Intel lists newer drivers here:

https://downloadcenter.intel.com/product/81500/Intel-HD-Graphics-3000-for-2nd-Generation-Intel-Core-Processors

The top entry is "9.17.10.4229".

~0004147

kent_elyue (reporter)

Last edited: 2015-11-26 04:40

View 2 revisions

My original drivers and subsequent updates came via Toshiba and/or Microsoft.

My update search next took me to the INTEL website. The Intel Driver website warned:

(begin quote)
Intel provides generic versions of drivers for general purposes. Your computer manufacturer may have altered the features, incorporated customizations, or made other changes to your driver. Intel recommends you contact your computer manufacturer for the latest system specific updates and technical support information.
(end quote)

Even though I don't know that I'm using a "special", "altered", or "custom" driver, I did (again) check for any newer Toshiba updates and there were none. Naturally, I'm somewhat reluctant to use their so-called "generic" driver lest I risk creating other problems - for me, or you, or anyone else.

I tried their Online Identification Tool, and their "IntelĀ® Driver Update Utility". The results were less than wonderful and even puzzling.

Their Identification Tool (both the Online Java version, and the Offline Installer version) says I'm currently using a driver version 9.17.10.3040. (I've uploaded their full ID-Tool report: siu_report_0331 1050.pdf)

However, the Intel Update Driver Utility that I installed and ran didn't even recognize any INTEL chipsets on my system when I ran it. That was Weird and frustrating! Needless to say it also wasn't particularly reassuring.

So I then risked checking Microsoft for a Driver update using Device Manager, and MS reported I was using the best and latest driver.

Sigh...

I was tempted to manually force update to this version from the Intel website:
IntelĀ® HD Graphics Driver for Windows* 7/8-64-bit
15.28.24.64.4229 (9.17.10.4229) dated 6/23/2015

I suppose that means the next step might be to create a Restore Point and try manually forcing an upgrade (I hope) to the 6/23/2015 version (9.17.10.4229) driver. I'd want to be sure I can do a problem-free roll-back if it causes me other headaches. The FAQ located here: http://www.intel.com/support/graphics/sb/CS-035775.htm describes the all-too-easy roll-back procedure, but then follows that with an ominous and foreboding warning of:

(being quote)
If the option to roll back driver is grayed-out, one of the following applies:
    ...
    * Your computer did not retain the driver files from the original version installed.
(end quote)

That's not something I want to encounter without a Plan B. :)

Sigh...

And just for the record, OpenClonk is a RARE GEM of a game. My wife and I love that we can work Co-operatively in the missions and scenarios. Kudos!! And Sincere gratitude to everyone involved in the project. Thank you from both of us!

~0004148

Sven2 (developer)

Yeah, well, since it affects many people we will have to find a solution that's working with the old Intel drivers anyway. We already know which part of the code fails on the Intel drivers, we just don't have a good workaround.

Maybe we just add an option to revert to software skinning.

~0004150

kent_elyue (reporter)

OK, and sincere thanks again for looking into this.

~0004151

kent_elyue (reporter)

Update:

I got brave and tried the newest INTEL Driver version 9.17.10.4229,
and the graphics glitch remains unresolved. (using nightly build from 2015-11-25)

Bummer.

In case it helps, I posted the OpenClonk.log file from the attempt with the newest drivers.

~0004198

Clonkonaut (developer)

Can confirm with Intel HD 2000.

~0005133

occ (reporter)

Hi! There's been a check-in that references this bug. For more information you can visit the repository browser at this address:
https://git.openclonk.org/openclonk.git/commitdiff/e9c5facf91ea201e909ab72b1ae845bbfb7201c7

Changeset e9c5fac by Nicolas Hake <isilkor@openclonk.org>
GL: Disable hardware-based skinning on old Intel devices

Our hardware-based skinning doesn't work on certain Intel graphics
devices. Fall back to software skinning on GPUs that return an OpenGL
3.1 context even though we explicitly request a 3.2 one.

Might fix 0001459, 0001689.

~0005136

Isilkor (developer)

I believe by using the old CPU based mesh skinning on (some) Intel devices this problem should be fixed; if it isn't, feel free to reopen.

~0005153

kent_elyue (reporter)

I feel really appreciative, but also very sad, when I imagine how much work must have been done to try and resolve this issue, and now the game crashes immediately upon -or perhaps even prior to- loading.

When I try to run the game executable, there is a brief flash of a tiny little window (up and left of center screen) and then nothing. The little window lasts less than a second, and only has the title bar containing the icon, minimize, restore, and close buttons visible. No menu. No title screen. Nothing else. The game just exits back to desktop without any error message, nor any other indication of what might have happened or failed.

I tried openclonk-snapshot-20160624-ef5b39a290-win32-amd64-mingw.zip and also
openclonk-snapshot-20160619-e9c5facf91-win32-amd64-mingw.zip

Thank you for your efforts. I wish I could report happier findings. Perhaps others can confirm or illuminate?

~0005156

Isilkor (developer)

Could you run either of those snapshots with a --debug-opengl parameter and upload the OpenClonk.log and possibly OpenClonkShaders.log (if it exists; it may be rather large but should compress well in a .zip or .gz)?

~0005157

kent_elyue (reporter)

Ok. Done.

I ran the Command: openclonk --debug-opengl

I uploaded the logfile as: OpenClonk(2016-06-26).log

Even though I saw little point in it, I did try to upload the file OpenClonkShaders.log. Unsurprisingly the upload failed. I expect that's because the file is actually empty, no data, and has a size of 0 bytes.

~0005159

Isilkor (developer)

Oh, I see; the driver fails to create a context and evidently we're not handling this properly. Since I don't think we're actually using OpenGL 3.2 Core features (we're just requesting that version because anything lower doesn't work on recent OS X and this makes it easier for us to write portable shaders and code), I think it should be fine for us to just fall back to requesting a 3.1 context in case 3.2 creation fails.

~0005166

occ (reporter)

Hi! There's been a check-in that references this bug. For more information you can visit the repository browser at this address:
https://git.openclonk.org/openclonk.git/commitdiff/36aa83b12865e32cad61746d49c16e32736ed41d

Changeset 36aa83b by Nicolas Hake <isilkor@openclonk.org>
Fix rendering on pre-3.2 hardware (0001459)

~0005167

Isilkor (developer)

Okay, I believe that should fix it; one of our devs was able to find a PC with an Intel GPU that doesn't support OpenGL 3.2 and rendering seems to work again. Editor mode might still fail or crash; if it does we probably won't address that issue before Sven's rewritten editor lands, sorry :(

~0005169

kent_elyue (reporter)

Seems a bit silly to me to "reopen" the issue just to say thanks and to confirm that it seems to be working fine now.

Anyhow, it looks great. Thanks again!

~0005173

ala (developer)

Last edited: 2016-06-28 09:14

View 2 revisions

Amazing, you really fixed it!
- even works on my old laptop. But one thing looks still off, that is the background of the Clonk in the dialogue window which is 'black' - I always assumed this was related, since I don't have it on the new computer.

I attached a screenshot of this.

[Edit] I see that the reporter didn't have those black backgrounds on his screenshot, so shall I open up a new bug for this?

~0005174

Isilkor (developer)

kent_eluye: You're welcome! I'm not guaranteeing that the game will continue working all the time (we don't officially support pre-3.2 hardware and none of the people working on the rendering code have an older Intel GPU available for testing), but we'll at least make an effort. May take a while though, like in this case ;-)

ala: That seems to be a different thing since it doesn't involve 3D meshes at all (the displayed portrait is a pre-rendered PNG file); I'll open a separate bug for it.
+Notes

-Issue History
Date Modified Username Field Change
2015-11-25 05:18 kent_elyue New Issue
2015-11-25 05:18 kent_elyue File Added: screenshot.172.jpg
2015-11-25 10:46 Maikel Note Added: 0004138
2015-11-25 16:33 kent_elyue File Added: screenshot.175.jpg
2015-11-25 16:39 kent_elyue Note Added: 0004140
2015-11-25 18:58 Sven2 Note Added: 0004141
2015-11-25 22:55 kent_elyue File Added: OpenClonk.log
2015-11-25 22:56 kent_elyue Note Added: 0004145
2015-11-25 23:51 Sven2 Note Added: 0004146
2015-11-25 23:52 Sven2 Note Edited: 0004146 View Revisions
2015-11-25 23:53 Sven2 Note Edited: 0004146 View Revisions
2015-11-26 00:05 Sven2 Note Edited: 0004146 View Revisions
2015-11-26 04:37 kent_elyue Note Added: 0004147
2015-11-26 04:39 kent_elyue File Added: siu_report_0331 1050.pdf
2015-11-26 04:40 kent_elyue Note Edited: 0004147 View Revisions
2015-11-26 05:09 Sven2 Note Added: 0004148
2015-11-26 15:46 kent_elyue Note Added: 0004150
2015-11-26 17:54 kent_elyue Note Added: 0004151
2015-11-26 17:56 kent_elyue File Added: OpenClonk(after_testing_newest_drivers).log
2015-11-30 14:06 Clonkonaut Note Added: 0004198
2015-11-30 14:06 Clonkonaut Status new => confirmed
2016-06-18 22:53 Clonkonaut Relationship added has duplicate 0001689
2016-06-19 11:48 occ Note Added: 0005133
2016-06-19 11:51 Isilkor Note Added: 0005136
2016-06-19 11:51 Isilkor Status confirmed => resolved
2016-06-19 11:51 Isilkor Resolution open => fixed
2016-06-19 11:51 Isilkor Assigned To => Isilkor
2016-06-26 03:09 kent_elyue Note Added: 0005153
2016-06-26 03:09 kent_elyue Status resolved => feedback
2016-06-26 03:09 kent_elyue Resolution fixed => reopened
2016-06-26 17:56 Isilkor Note Added: 0005156
2016-06-26 21:31 kent_elyue File Added: OpenClonk(2016-06-26).log
2016-06-26 21:38 kent_elyue Note Added: 0005157
2016-06-26 21:38 kent_elyue Status feedback => assigned
2016-06-26 22:47 Isilkor Note Added: 0005159
2016-06-27 11:53 occ Note Added: 0005166
2016-06-27 11:58 Isilkor Note Added: 0005167
2016-06-27 11:58 Isilkor Status assigned => resolved
2016-06-27 11:58 Isilkor Resolution reopened => fixed
2016-06-27 13:35 kent_elyue Note Added: 0005169
2016-06-27 13:35 kent_elyue Status resolved => feedback
2016-06-27 13:35 kent_elyue Resolution fixed => reopened
2016-06-28 09:12 ala Note Added: 0005173
2016-06-28 09:12 ala File Added: Black Dialogue Background.png
2016-06-28 09:14 ala Note Edited: 0005173 View Revisions
2016-06-28 09:21 Isilkor Note Added: 0005174
2016-06-28 09:21 Isilkor Status feedback => resolved
2016-06-28 09:21 Isilkor Resolution reopened => fixed
+Issue History