Anonymous Login
2020-08-12 17:55 UTC

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0001447OpenClonkObjectspublic2016-01-20 08:46
Assigned ToMaikel 
PlatformWindows 7 64bitOSOS Version
Product Version 
Target VersionFixed in Version 
Summary0001447: Energy Distribution broken
DescriptionIf you look at the screenshot, the armory and the battery underground got no energy even if the energy radius was reaching below. We had 2 windmills and a power plant for energy, the power plant didn't even start to burn coal (if I recall it only does if more energy is needed).
TagsNo tags attached.
Attached Files




Shadow (reporter)

Tested with current snapshot (20151120-c247d6f145-win32-amd64-mingw)


Maikel (developer)

Last edited: 2015-11-21 18:22

View 3 revisions

Were you several players which may have been possible, I can't reproduce this at the moment. A savegame with the snapshot version would be good as well.


Shadow (reporter)

Uploaded another screen, we couldn't build items so that we had to abort. Even building new tool workshops didn't help.


Armin (reporter)

Happened to me, too.

I was able to create a hammer with the workshop. And when I tried to create a pickaxe, the workshop had no energy. Something weird happens in a timer or maybe another energy consuming building joined the circle and even if the new building did nothing, something may changed in a way.


Zapper (developer)

Last edited: 2015-11-21 22:48

View 2 revisions

Maikel, I attached the savegame from my round with ala.

Jump down from the sky island where you spawn and get into the base. Underground you will find a broken compensator and a broken armory. Right from the base you can find a steam engine full with coal which doesn't ever do anything (I think?).

We were two players. We also might have lost/added producers and consumers at arbitrary points.

This is a really urgent bug as it can be game breaking.

PS: ala is "Shadow" right now and the savegame comes from the snapshot he posted above.


Sven2 (developer)

Last edited: 2015-11-22 04:09

View 3 revisions

I added a fix to a power-related script error after the mentioned commit. Does that fix it?

(Unfortunately it looks like my commit was just a few hours after the snapshot you used)

By the way, maybe the power system should re-initialize itself from the basic values (flag radiuses, power production, power consumption and requested power need) on savegame resume?


ala (developer)

No, I don't think that fix helped - we had the same problem yesterday in the Snapshot: 2015-11-21 12:35 , 320b6ecad0


Maikel (developer)

That problem from yesterday seems relatively simple. I have a hard time figuring out what is wrong here. Do you have a savegame from yesterday? Or maybe the details on what you did in this round?


ala (developer)

We started flooded Veins, 2 players (me and mcGreen), you have a base with some starting building - including a windmill, tool workshop, chemical labratory.

-So we build an elevator outside the base.
-We build a flag to connect it to the base, elevator worked.

We tried to build explosives, chemical lab claims to have no energy (which was not true, windmill was turning, elevator could run)
We tried to create a line kit, same as above
I build a completely new toolshoop, same as above

We aborted the round.


In the Zapper round (gemgrabber), again two players we build:
Flag, elevator, windmill, sawmill which worked.
An armory and a battery underground - which didn't work
A battery overground which did work, several more windmills and a power plant to ensure definite power overflow.


Maikel (developer)

I can't reproduce this in a controlled test and somehow the savegames and screenshots are not that useful. Please let me know as soon as it appears again with as many details as possible. Logs, savegames, screenshot of the set-up and which events happened (buildings destroyed, players left, etc.).


Sven2 (developer)

Yes please copy the log file. Usually there's nil pointers that cause scripts to cancel. Also press Ctrl+F5 in the game to enable debug mode, so you can see if there's any script errors.


ala (developer)

Last edited: 2015-11-25 14:16

View 2 revisions

If you still can't reproduce we can play online tomorrow, or even today for a quick check (just starting flooded veins and trying to produce something).

It's a very important bug, since we had a tiny active player base recently!


Maikel (developer)

ala and I have played some test rounds trying to reproduce the bugs described here and failed, everything seems to work.

However, I have found a possible problem when a producer moves out of the energy radius of the base and then moves back in while producing. I will investigate this further.

This bug will remain open, so please report any problem you find.


Maikel (developer)

Last edited: 2015-11-27 09:45

View 2 revisions

Zapper: I have found a bug, where the producer moves out of the energy radius of a base. First of all it will only run out of energy when the next item is taken from the queue. And then it will never get any power as its request is not taken by a network.

I will fix this, however, I'd like to know what the intended behaviour for ownership of the structure should be if it moves outside of a base radius? Should it change to NO_OWNER or stick to its original owner?


Zapper (developer)

It should change to NO_OWNER. At least that's what was intended from the beginning on.

Might well be that we are going to encounter some bugs with that once we have decent base melees where you can actually take over flagpoles. But for now I'd say, it should change the owner.


Maikel (developer)

The found bug has been fixed, I am not sure whether this is also the issue initially described in this report. So please report a new bug or reopen this one if the issue still appears on snapshot.

-Issue History
Date Modified Username Field Change
2015-11-20 22:33 Shadow New Issue
2015-11-20 22:33 Shadow File Added: No Energy.png
2015-11-20 22:44 Shadow Note Added: 0004118
2015-11-21 18:20 Maikel Note Added: 0004121
2015-11-21 18:20 Maikel Assigned To => Maikel
2015-11-21 18:20 Maikel Status new => feedback
2015-11-21 18:22 Maikel Note Edited: 0004121 View Revisions
2015-11-21 18:22 Maikel Note Edited: 0004121 View Revisions
2015-11-21 19:10 Shadow File Added: Energy Bug 2.png
2015-11-21 19:11 Shadow Note Added: 0004122
2015-11-21 19:11 Shadow Status feedback => assigned
2015-11-21 19:49 Armin Note Added: 0004123
2015-11-21 22:46 Zapper File Added: GemGrabbers1.ocs
2015-11-21 22:48 Zapper Note Added: 0004124
2015-11-21 22:48 Zapper Note Edited: 0004124 View Revisions
2015-11-22 04:08 Sven2 Note Added: 0004125
2015-11-22 04:09 Sven2 Note Edited: 0004125 View Revisions
2015-11-22 04:09 Sven2 Note Edited: 0004125 View Revisions
2015-11-22 06:32 ala Note Added: 0004126
2015-11-22 07:34 Maikel Note Added: 0004127
2015-11-22 09:13 ala Note Added: 0004129
2015-11-22 11:08 Maikel Note Added: 0004130
2015-11-22 16:12 Sven2 Note Added: 0004131
2015-11-25 11:23 ala Note Added: 0004139
2015-11-25 14:16 ala Note Edited: 0004139 View Revisions
2015-11-25 18:51 ala Target Version => 7.0
2015-11-26 08:33 Maikel Note Added: 0004149
2015-11-26 22:35 Maikel Note Added: 0004153
2015-11-26 22:35 Maikel Status assigned => feedback
2015-11-27 09:45 Maikel Note Edited: 0004153 View Revisions
2015-11-27 18:47 Zapper Note Added: 0004154
2015-11-28 17:06 Maikel Note Added: 0004156
2015-11-28 17:06 Maikel Status feedback => resolved
2015-11-28 17:06 Maikel Resolution open => fixed
+Issue History