Anonymous Login
2019-09-22 03:48 UTC

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0000013OpenClonkEnginepublic2013-11-06 11:17
Reporterxy77 
Assigned ToIsilkor 
PrioritynormalSeveritycrashReproducibilityalways
StatusclosedResolutionunable to reproduce 
Product Version 
Target VersionFixed in Version 
Summary0000013: clonk won't start on Ubuntu Linux 9.04 after compile
DescriptionCompile went fine with g++, but starting the game results in some error messages related to graphic files.
Additional Information[00:31:25] Using XRandR version 1.3
Warning: ForEachFile with * (<path>/clonk-os/openclonk/./*.c4p)
[00:31:25] Registration key is too old for this version.
[00:31:25] No valid key file found.
[00:31:25] Translation Deutsch is not in UTF-8, skipped
[00:31:25] Translation English is not in UTF-8, skipped
[00:31:25] Command line:
[00:31:25] ""
[00:31:25] OpenClonk Beta (Blue)
[00:31:25] Version: 4.10.0.0 [401] Beta linux
[00:31:25] Registration key is too old for this version. No valid key file found.
[00:31:25] Size of GammaRamp is 1024, not 256
[00:31:25] Using OpenGL...
[00:31:26] No Gamepad found
[00:31:26] Fehler bei Grafikdatei CursorMedium: Datei nicht gefunden oder ungltig.
[00:31:26] Fehler bei Grafikdatei CursorMedium: Datei nicht gefunden oder ungltig.
[00:31:26] Fehler bei Grafikdatei CursorMedium: Datei nicht gefunden oder ungltig.
[00:31:27] Grafik wird geladen...
[00:31:28] Fehler bei Grafikdatei EnergyBars: Datei nicht gefunden oder ungltig.
[00:31:28] Spiel deinitialisiert.
[00:31:28] Engine heruntergefahren.
TagsNo tags attached.
Attached Files

-Relationships
related to 0000014closedIsilkor No Music / Sound 
+Relationships

-Notes

~0000034

Isilkor (developer)

Do you start the application from wherever it builds to? If so, does the game still not start when you launch it from the directory <source>/planet?

~0000035

xy77 (reporter)

It doesn't matter. I can start it from the build source, from ./planet via ../clonk or installed from /usr/local/bin/clonk. Error output is always the same. Though the messages with CursorMedium seem to have disappeared.

~0000039

xy77 (reporter)

Ah, my fault. I copied some of the c4* files from an old clonk rage installation to the source folder. clonk probably checked those files for the missing graphic file.
What did work is: copying the clonk executable to the planet folder. Simply executing it from the parent folder didn't work.
I can then run the application and start the testlevel.

~0000040

Isilkor (developer)

Last edited: 2009-07-04 13:59

> What did work is: copying the clonk executable to the planet folder. Simply executing it from the parent folder didn't work.
I'm having the same problem on win32 and it seriously annoys me while debugging. Which is weird, because I seem to remember that you *could* run clonk from different working directories, but the source disagrees with me.

~0000055

Isilkor (developer)

> [00:31:25] Translation Deutsch is not in UTF-8, skipped
> [00:31:25] Translation English is not in UTF-8, skipped
Regarding this: Did you use the game data of Clonk Rage, or the ones from the OpenClonk repository?

~0000056

xy77 (reporter)

These errors did occur using the Clonk Rage game data files. It does not happen starting clonk from ./planet.

~0000057

Isilkor (developer)

Please reopen if this bug also appears with current OpenClonk game data.
+Notes

-Issue History
Date Modified Username Field Change
2009-06-30 22:33 xy77 New Issue
2009-07-01 20:47 Isilkor Note Added: 0000034
2009-07-01 21:25 xy77 Note Added: 0000035
2009-07-01 23:32 Isilkor Relationship added related to 0000014
2009-07-04 11:45 xy77 Note Added: 0000039
2009-07-04 13:58 Isilkor Note Added: 0000040
2009-07-04 13:59 Isilkor Note Edited: 0000040
2009-07-10 18:16 Isilkor Note Added: 0000055
2009-07-10 21:34 xy77 Note Added: 0000056
2009-07-11 01:49 Isilkor Note Added: 0000057
2009-07-11 01:49 Isilkor Status new => resolved
2009-07-11 01:49 Isilkor Resolution open => unable to reproduce
2009-07-11 01:49 Isilkor Assigned To => Isilkor
2009-10-14 23:12 Isilkor Status resolved => closed
2013-11-06 11:17 Newton Fixed in Version => 1.0
+Issue History