Anonymous Login
2019-11-17 17:56 UTC

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0000011OpenClonkObjectspublic2013-11-06 16:53
ReporterMrBeast 
Assigned ToIsilkor 
PrioritynormalSeveritytrivialReproducibilityhave not tried
StatusclosedResolutionfixed 
Product Version 
Target VersionFixed in Version 
Summary0000011: unsuitable ConfigurationFolder
DescriptionActually openClonk uses ~/.clonk/zoom for the configurqation.

It would be more suitable to use "~/.clonk/openclonk/" or (which is better i think) "~/.openclonk/"
TagsNo tags attached.
Attached Files

-Relationships
+Relationships

-Notes

~0000030

Isilkor (developer)

I've changed the engine name to OpenClonk, but I'd prefer to keep the config inside ~/.clonk/ somewhere, since it's in principle just a free version of Clonk. Any feedback?

~0000031

MrBeast (reporter)

Hm.. i've thought about "~/.openclonk" because it shows that it is a new thing and have not much to do with the "old" clonk series.

~0000067

Ape (reporter)

The new recommendations suggests using the ~/.config/ directory for this kind of configuration files. So I'd vote for ~/.config/openclonk/ . The goal with the usage of ~/.config/ is to keep home folder clean.

~0000076

Isilkor (developer)

It should rather be stored in $XDG_CONFIG_HOME, if I interpret http://standards.freedesktop.org/basedir-spec/basedir-spec-latest.html correctly (though that defaults to ~/.config if the var is unset), while non-config data belongs into $XDG_DATA_HOME (~/.local/share). This seems to be The Right Way™ to do it then.

~0000212

Newton (administrator)

It's in ~/.clonk/openclonk/, someone changed it but didnt close this report.
+Notes

-Issue History
Date Modified Username Field Change
2009-06-19 21:03 MrBeast New Issue
2009-06-21 12:35 Isilkor Note Added: 0000030
2009-06-21 12:35 Isilkor Status new => feedback
2009-06-21 16:47 MrBeast Note Added: 0000031
2009-07-16 11:26 Ape Note Added: 0000067
2009-07-25 15:02 Isilkor Note Added: 0000076
2010-01-24 14:03 Newton Status feedback => assigned
2010-01-24 14:03 Newton Assigned To => Isilkor
2010-01-24 14:04 Newton Note Added: 0000212
2010-01-24 14:04 Newton Status assigned => resolved
2010-01-24 14:04 Newton Resolution open => fixed
2013-11-06 11:53 Newton Fixed in Version => 1.0
2013-11-06 16:53 Newton Status resolved => closed
+Issue History