OpenClonk Bugtracker - OpenClonk
View Issue Details
0001733OpenClonkObjectspublic2016-05-01 15:542019-03-31 18:25
Assigned ToMarky 
PlatformOSOS Version
Product Versiongit master 
Target Version9.0Fixed in Version9.0 
Summary0001733: Library_Vendor: rename QueryRebuy to e.g. QueryRejectRebuy
DescriptionThe callback is used to be able to disallow (rejecting) rebuying. The callback name should reflect that in some way.

Following the naming scheme of our other callbacks (e.g. QueryRejectDeparture, QueryRejectDeselection) it should probably be that.

Other than that, seeing the name of "QueryRebuy", I wouldn't know what that is supposed to do.

("QueryOnSell" is similar. That should probably be just "OnSell" - but meh..)
Additional Informationrelated:
TagsNo tags attached.
Attached Files

There are no notes attached to this issue.

Issue History
2016-05-01 15:54ZapperNew Issue
2017-08-20 11:48ZapperTarget Version8.0 => 9.0
2019-03-31 18:25MarkyAssigned To => Marky
2019-03-31 18:25MarkyStatusnew => resolved
2019-03-31 18:25MarkyResolutionopen => fixed
2019-03-31 18:25MarkyFixed in Version => 9.0