Anonymous Login
2017-09-20 11:05 CEST

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0001806OpenClonkObjectspublic2017-08-18 17:08
ReporterFulgen 
Assigned ToMaikel 
PrioritynormalSeverityminorReproducibilityalways
StatusresolvedResolutionno change required 
Product Version 
Target Version8.0Fixed in Version 
Summary0001806: Ownership area blocks can overlap each other
DescriptionOwnership area blocks can overlap each other.
Steps To ReproducePlace a flag near a power crystal in Acid Drilling. The area of the flag overlaps the crystals' one , but you can't build in the overlapped area.
TagsNo tags attached.
Attached Files

-Relationships
+Relationships

-Notes

~0005237

Maikel (developer)

Blocking ownership areas is also done in my Basemelees project, a consistent way to do this would be useful.

~0005249

Zapper (developer)

Putting flags with other owners seems like a pretty consistent way. The problem seems to be that someone broke the overlap check for hostile flags in general?

~0005250

Maikel (developer)

The problem is that I want rectangular areas as well.

~0005737

Maikel (developer)

Closed this, one cannot build flags near the crystals.
+Notes

-Issue History
Date Modified Username Field Change
2016-08-09 12:57 Fulgen New Issue
2016-08-09 17:35 Maikel Note Added: 0005237
2016-08-11 22:50 Zapper Note Added: 0005249
2016-08-15 19:32 Maikel Note Added: 0005250
2017-08-05 15:58 Maikel Target Version => 8.0
2017-08-18 17:08 Maikel Note Added: 0005737
2017-08-18 17:08 Maikel Assigned To => Maikel
2017-08-18 17:08 Maikel Status new => resolved
2017-08-18 17:08 Maikel Resolution open => no change required
+Issue History