Anonymous Login
2017-11-21 15:00 CET

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0001535OpenClonkEngine - Controlspublic2016-08-19 11:38
ReporterMupf 
Assigned ToClonk-Karl 
PrioritynormalSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
PlatformLinuxOSUbuntu GNOMEOS Version15.04
Product Version 
Target Version7.0Fixed in Version7.0 
Summary0001535: Mouse Wheel not working under Linux
DescriptionIn the current snapshot (and many snapshots before that), the mouse wheel only works for one or two "clicks" per round, then stops functioning completely.
This is true for both zooming and scrolling though items and is reset again by starting a new round.
Steps To ReproduceStart a round in Linux, scroll the mouse wheel.
Additional InformationThe problem does not occur under Windows 7.
TagsNo tags attached.
Attached Files

-Relationships
has duplicate 0001520closedClonk-Karl Scroll wheel doesn't work properly 
+Relationships

-Notes

~0004462

Clonk-Karl (administrator)

For me it behaves slightly differently: the mouse wheel does not work when I press another key, such as walking with the Clonk. When stopped pressing any other keys, the mouse wheel works again.

~0004463

Maikel (developer)

Last edited: 2016-01-05 09:58

View 2 revisions

You are not on a QWERTY/Z keyboard or?

Do you have any idea what might cause this?

I tried to bisect this but could not find a commit that works and I went back in time as far is 4.0. Maybe someone else has more luck?

~0004464

Clonkonaut (developer)

Are you suggesting that the mouse wheel never worked under linux? %)

~0004465

Maikel (developer)

I know it has worked for me, maybe when I changed to Ubuntu 14.04 it stopped working? Maybe OC can't handle some new way Linux OSes pass mouse wheel commands.

I wonder how we can trace this thing down. I'd love to help but have no idea what could be the cause and where to look.

~0004466

Armin (reporter)

For a few month, I have the same problem as Mupf. It doesnt matter whether I walk or not.

I also noted that I do not have this problem when playing a scen in editor mode.

~0004467

Clonk-Karl (administrator)

Maikel: I'm using Dvorak, but I can hardly imagine that making a difference.

~0004468

Clonk-Karl (administrator)

I'll look into this ASAP.

~0004470

Clonk-Karl (administrator)

GTK+ does not seem to deliver scroll events at all when a key is pressed at the same time... maybe because it assumes that if you have a textbox or something it's not a good idea to scroll it in that case.

We might be able to work around it by intercepting the raw X scroll event instead.

~0004471

Maikel (developer)

Did this happen because of the GKT+ update we had? (from 2.0 to 3.0 iirc)

That workaround sounds quite necessary of the key is not registered.

~0004472

Clonk-Karl (administrator)

Maybe, or maybe it used to work with some older versions of GTK 3 but not with what's shipped by Ubuntu 14 or Debian 8. Note that we had GTK 3 support for a long time, it's just that we removed the GTK 2 one a while ago.

~0004500

Clonk-Karl (administrator)

The problem was that we had both "normal" and "smooth" scrolling enabled, and probably the way these scroll events get delivered to the application has changed in some GTK version. I disabled smooth scrolling for now. OpenClonk was not very sophisticated in interpreting them anyway, e.g. my touchpad generated deltas close to 0, and OpenClonk rounded the value to the nearest integer, thereby throwing away all the "smooth" information.

~0004504

Maikel (developer)

I can confirm that this is also fixed on my system now. Thanks a lot.

~0005297

Newton (administrator)

arhiving old resolved bugs
+Notes

-Issue History
Date Modified Username Field Change
2016-01-03 23:43 Mupf New Issue
2016-01-03 23:45 Clonkonaut Relationship added has duplicate 0001520
2016-01-03 23:45 Clonkonaut Status new => acknowledged
2016-01-03 23:46 Clonkonaut Target Version => 7.0
2016-01-05 06:39 Clonk-Karl Note Added: 0004462
2016-01-05 09:24 Maikel Note Added: 0004463
2016-01-05 09:58 Maikel Note Edited: 0004463 View Revisions
2016-01-05 11:54 Clonkonaut Note Added: 0004464
2016-01-05 12:24 Maikel Note Added: 0004465
2016-01-05 14:37 Armin Note Added: 0004466
2016-01-05 16:22 Clonk-Karl Note Added: 0004467
2016-01-05 16:22 Clonk-Karl Note Added: 0004468
2016-01-05 16:22 Clonk-Karl Assigned To => Clonk-Karl
2016-01-05 16:22 Clonk-Karl Status acknowledged => assigned
2016-01-06 07:58 Clonk-Karl Note Added: 0004470
2016-01-06 09:17 Maikel Note Added: 0004471
2016-01-06 16:05 Clonk-Karl Note Added: 0004472
2016-01-09 05:58 Clonk-Karl Note Added: 0004500
2016-01-09 05:58 Clonk-Karl Status assigned => resolved
2016-01-09 05:58 Clonk-Karl Fixed in Version => 7.0
2016-01-09 05:58 Clonk-Karl Resolution open => fixed
2016-01-09 13:34 Maikel Note Added: 0004504
2016-08-19 11:38 Newton Note Added: 0005297
2016-08-19 11:38 Newton Status resolved => closed
+Issue History