Anonymous Login
2017-11-21 14:56 CET

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0001529OpenClonkEnginepublic2016-08-19 11:38
ReporterClonkonaut 
Assigned ToClonk-Karl 
PrioritylowSeveritymajorReproducibilityN/A
StatusclosedResolutionfixed 
PlatformPCOSWindowsOS Version8.1
Product Version 
Target Version7.0Fixed in Version7.0 
Summary0001529: Disable splitscreen
DescriptionWe should consider disabling splitscreen. The easiest way I can think of right now is to prevent a local client from selecting more than one player in the menu (we can ignore people who hack the registry).

There are several issues connected to splitscreen:

With no working gamepad controls, there is no way a second player can ever participate in the game.
The new GUI menus do not work on a second screen. They are always shown on the first screen, they use the whole screen resolution for reference and get wrong mouse coordinates so the first player can't even control his own menus.

If anyone ever manages to activate a second player, he will get what looks like an unfinished feature.
TagsNo tags attached.
Attached Files

-Relationships
+Relationships

-Notes

~0004442

Sven2 (developer)

Last edited: 2016-01-02 19:20

View 2 revisions

Multiple local players are required for testing multiplayer scenarios, so at least it should be not disabled in editor mode.

I wouldn't want to disable it "too deeply" because gamepad support and script gui should be fixed and then splitscreen is still a good feature. There could be a #define which is evaluated and then disables join buttons in the game and lobby.

~0004443

Clonkonaut (developer)

I didn't intend to remove local multiplayer from the game, yes. Just hide the options to regular players.

A define sounds good. But then we still need to make sure that not more than one player is selected in the player selection menu.

~0004451

Sven2 (developer)

Yes. On the startup screens (Player label in main menu; list box in player selection screen), selecting a new player could just deselect all previously selected players.

~0004453

Marky (developer)

Originally I wanted to use the split screen feature for the Open Clonk Classic project, the idea was to have multiple keyboard layouts for the other players, similar to the old CR layouts, so that at least 2 players can play with one keyboard.
The other thing that would be pretty neat is the possibility to have two (local) players use the same layout, but pass the controls to another player (see the turn-based hot-shots scenario). This could be realized via script though, I think.

Anyway, these are both very specific applications for user-created content and I think the main game can do fine without split screen.
Even better, if I ever realize the viewport-object, then we could have a scripted pseudo-split-screen again anyway.

~0004458

Maikel (developer)

Maybe we can prohibit selecting a player with the same control set as another player as well, as a separate thing.

~0004459

Clonkonaut (developer)

We might want to do that but it can wait until we have again full splitscreen and gamepad support. ;)

~0004551

Clonk-Karl (administrator)

Only one player is selectable in the menu now.

~0005272

Newton (administrator)

arhiving old resolved bugs
+Notes

-Issue History
Date Modified Username Field Change
2016-01-02 01:44 Clonkonaut New Issue
2016-01-02 01:45 Clonkonaut Description Updated View Revisions
2016-01-02 19:18 Sven2 Note Added: 0004442
2016-01-02 19:20 Sven2 Note Edited: 0004442 View Revisions
2016-01-02 20:19 Clonkonaut Description Updated View Revisions
2016-01-02 20:39 Clonkonaut Note Added: 0004443
2016-01-03 00:53 Sven2 Note Added: 0004451
2016-01-03 17:33 Marky Note Added: 0004453
2016-01-04 13:21 Maikel Note Added: 0004458
2016-01-04 13:57 Clonkonaut Note Added: 0004459
2016-01-12 03:33 Clonk-Karl Note Added: 0004551
2016-01-12 03:33 Clonk-Karl Status new => resolved
2016-01-12 03:33 Clonk-Karl Fixed in Version => 7.0
2016-01-12 03:33 Clonk-Karl Resolution open => fixed
2016-01-12 03:33 Clonk-Karl Assigned To => Clonk-Karl
2016-08-19 11:38 Newton Note Added: 0005272
2016-08-19 11:38 Newton Status resolved => closed
+Issue History