Anonymous Login
2017-05-25 16:20 CEST

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0001511OpenClonkEngine - Graphicspublic2017-03-26 14:44
ReporterK-Pone 
Assigned ToIsilkor 
PrioritynormalSeveritycrashReproducibilityalways
StatusresolvedResolutionwon't fix 
PlatformNotebook (Dell Latitude E5500)OSWindows 7 Professional 32-bitOS Version7
Product Version 
Target VersionFixed in Version 
Summary0001511: OpenGL Error when starting scenario
DescriptionIt's not possible to start a game in the current 7.0 snapshot version on this Notebook. The main menu works fine.

This is what the Notebook provides:

CPU: Intel Core 2 Duo (2 Cores) 2.4 GHz
Memory: 4 GB RAM
GPU: Mobile Intel 4 Series Express Chipset Family (Onboard Graphics, shared Memory)
OS: Windows 7 Professional 32-bit Version
The Notebook is from 2009
Additional InformationThis is the OpenClonk.log:

[15:52:20] OpenClonk
[15:52:20] Version: 7.0-alpha0 win win-x86 (9da914dd2268)
[15:52:20] ExePath: "C:\Users\K-Pone\Downloads\openclonk-snapshot-20151221-9da914dd22-win32-i386-mingw\"
[15:52:20] SystemDataPath: "C:\Users\K-Pone\Downloads\openclonk-snapshot-20151221-9da914dd22-win32-i386-mingw\"
[15:52:20] UserDataPath: "C:\Users\K-Pone\AppData\Roaming\OpenClonk\"
[15:52:20] Command line: C:\Users\K-Pone\Downloads\openclonk-snapshot-20151221-9da914dd22-win32-i386-mingw\openclonk.exe
[15:52:20] gl: Create first context...
[15:52:20] GL 2.1.0 - Build 8.15.10.2302 on Mobile Intel(R) 4 Series Express Chipset Family (Intel)
[15:52:20] WARNING (particle system): Your graphics card does not support glPrimitiveRestartIndex - a (slower) fallback will be used!
[15:52:20] Grafik wird geladen...
[15:52:22] OpenAL extensions loaded. ON: 1, 4, 12. OFF: .
[15:52:25] Musik: UrbanBolero.ogg
[15:52:43] Szenario: C:\Users\K-Pone\Downloads\openclonk-snapshot-20151221-9da914dd22-win32-i386-mingw\\Worlds.ocf\GoldRush.ocs
[15:52:43] Szenario benutzt vorgegebene Objektdefinitionen.
[15:52:43] Extras werden geladen...
[15:52:44] Grafik wird geladen...
[15:52:45] Objektdefinitionen werden geladen:
[15:52:45] Objects.ocd...
[15:52:58] 356 Definitionen geladen.
[15:52:58] Worlds.ocf...
[15:52:58] 0 Definitionen geladen.
[15:52:58] GoldRush.ocs...
[15:52:58] 0 Definitionen geladen.
[15:52:59] C4AulScriptEngine linked - 65687 lines, 0 warnings, 0 errors
[15:52:59] Texturtabelle mit 34 Eintr├Ągen geladen.
[15:52:47] 46 Texturen geladen.
[15:52:47] 24 Materialien geladen.
[15:52:48] Erstellung der Landschaft...
[15:52:50] gl: Could not load textures (error 1280)
[15:52:50] FATALER FEHLER: [!] Could not initialize landscape textures for rendering!
[15:52:50] FATALER FEHLER: Fehler beim Landschaftsgenerator.
[15:52:51] Spiel deinitialisiert.
[15:52:51] Grafik wird geladen...
[15:52:52] OpenAL extensions loaded. ON: 1, 4, 12. OFF: .
[15:52:56] Musik: UrbanBolero.ogg
[15:52:57] [Msg] Fehlermeldungen: [!] Could not initialize landscape textures for rendering!|Fehler beim Landschaftsgenerator.
[15:53:22] Spiel deinitialisiert.
[15:53:22] Engine heruntergefahren.
TagsNo tags attached.
Attached Files

-Relationships
+Relationships

-Notes

~0004355

Clonk-Karl (administrator)

Can you start the game with --debug-opengl and re-post the OpenClonk.log?

~0004376

K-Pone (developer)

@Clonk-Karl: I can, as soon as I have the notebook with me again. (probably 2nd January)

~0004386

Isilkor (developer)

Last edited: 2015-12-25 01:48

View 2 revisions

It's an ancient Intel driver, it doesn't support GL_ARB_debug_output. But I can tell you what the problem is anyway: That GPU doesn't support OpenGL higher than 2.1 (GLSL 1.20).

e: Oh and apparently it also has GL_MAX_VERTEX_UNIFORM_COMPONENTS as 512, which is half of what the spec requires as a minimum (and what OpenClonk requires as a minimum as well).

~0004809

Clonk-Karl (administrator)

So 7.0 should work fine with OpenGL 2.1. However, even then it might not be able to run the game due to the maximum uniform constraints Isilkor mentioned. Anyway, does it work for you, K-Pone?

For current master (8.0 and beyond) we'll require OpenGL 3.

~0005633

Isilkor (developer)

We'll require OpenGL 3 support starting with the next version, so we won't fix this.
+Notes

-Issue History
Date Modified Username Field Change
2015-12-21 16:09 K-Pone New Issue
2015-12-21 17:57 Clonk-Karl Note Added: 0004355
2015-12-22 18:21 K-Pone Note Added: 0004376
2015-12-25 01:39 Isilkor Note Added: 0004386
2015-12-25 01:48 Isilkor Note Edited: 0004386 View Revisions
2016-01-18 07:21 Clonk-Karl Note Added: 0004809
2017-03-26 14:44 Isilkor Assigned To => Isilkor
2017-03-26 14:44 Isilkor Status new => resolved
2017-03-26 14:44 Isilkor Resolution open => won't fix
2017-03-26 14:44 Isilkor Note Added: 0005633
+Issue History