Anonymous Login
2017-11-21 14:57 CET

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0001365OpenClonkEngine - GUIpublic2016-08-19 11:38
Reporterala 
Assigned ToMaikel 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
Product Version 
Target Version7.0Fixed in Version7.0 
Summary0001365: Can't see required construction site materials if construction site is directly over the bottom
DescriptionCan't see required construction site materials if construction site is directly over the bottom
Steps To ReproduceNightly 03-08-2015
TagsNo tags attached.
Attached Files

-Relationships
related to 0001364closedZapper Buildmenu texts are rendered before anything else 
related to 0001434new Display certain information in an information overlay 
+Relationships

-Notes

~0003985

Zapper (developer)

I added the missing construction material to the interaction menu now. So at least you can check what is missing there.

Do we really still need the message below the building? I mean, I obviously see the use for it: you know what is missing without visiting the building (especially if maybe one of your team mates is also constructing). But it's imo not really good communication with the players (small symbols that you need to learn first - not really helpful for new players).

Also related to 0001364.

~0003988

Sven2 (developer)

Last edited: 2015-10-23 21:22

View 2 revisions

I do like the messages. When you're not at the site, it's absolutely crucial to know the needed materials in multiplayer.

Another option would be to have a "highlight information frame", which is shown around the building if you hover your mouse over it. It could display energy bars for allied structures, required materials, current jobs in queue, etc. For clonks it could show the player name and hostility. For crops it could show whether it's harvestable. It could also give a quick hint whether you can press "Space" or "E" to do interactions.

It might even be possible to implement this using script GUI? Is it possible to show a GUI only when hovered by mouse? Or would it slow down the game to have a million invisible GUIs? (in that case, it could be sync and only constructed as you actually hover the mouse).

~0003989

Zapper (developer)

I actually implemented something like that very early in the controls branch. But it was more annoying than helpful (and I even only showed it when right-clicking the building)...

Don't forget that you automatically hover over buildings etc. when just walking through the landscape.

~0003992

Sven2 (developer)

How was it "annoying" if it even required a mouse button press? Also these highlights at least with energy bars are common in RTS. Maybe we're just missing a way (fonts...) to display information in a none-annoying way?

~0004001

Zapper (developer)

Well, annoying might be the wrong word. It was distracting and intrusive.

But that might also be because that was the predecessor of the current interaction menu and I wanted to put literally /everything/ in there.

I guess a minimal display could work.

What about showing an information overlay with a key press? It could show the energy levels (and thus get rid of the always-on lightbulbs), the base radii (and thus get rid of the flag markers) and indicate damaged buildings. And of course also show the material requirements for construction sites.
(And, in the future, stuff like which lever is connected to which door.)

Clonk really is more of an RTS than, say, Terraria. And maybe we shouldn't be afraid to play that card.

~0004002

Sven2 (developer)

Last edited: 2015-10-24 19:53

View 2 revisions

Holding "alt" to show energy bars was a key in Warcraft 3 and that worked. But it might be confusing if light bulbs, energy bars, markers and more stuff in the future suddenly pops up all over the screen (as opposed to having it only on the hovered object).

~0004005

Zapper (developer)

"Hovering" is a concept that does not exist for gamepads, though. And if we can keep that to a minimum (i.e. HP bars only for damaged stuff, energy bulbs only for active producers/consumers, flag radius ideally with real drawn lines or something) it might be fine?

~0004007

Sven2 (developer)

I don't know. It's something we'd need to try out I guess.

Gamepads would need another extra button to show the info then? Or define a minimal set that is always shown when gamepad is used?

By the way: Maybe defer this to 8.0 (unless someone want to work on this?). The construction site message problems can be hotfixed relatively easily for 7.0 I'd think (show non-GUI object messages behind GUI and expand viewport clipping to outer scroll border instead of landscape border for messages)

~0004011

Zapper (developer)

>By the way: Maybe defer this to 8.0 (unless someone want to work on this?)

Yeah, good point. We have a lot of other stuff to do now and this really is a stand-alone thing.

>[...] expand viewport clipping to outer scroll border instead of landscape border for messages)
Sounds good!

>[...] show non-GUI object messages behind GUI
Also fine. That's probably just changing the order of two draw calls somewhere.

~0004014

Clonkonaut (developer)

I made a new feature report for the info things.

Does anyone plan to do the two tasks?

- Expand viewport clipping to outer scroll border instead of landscape border for messages

- show non-GUI object messages behind GUI

~0004517

Maikel (developer)

Hotfix implemented, this discussion can be put into new bug reports if needed.

~0005290

Newton (administrator)

arhiving old resolved bugs
+Notes

-Issue History
Date Modified Username Field Change
2015-08-03 01:43 ala New Issue
2015-10-16 02:33 Sven2 Target Version => 7.0
2015-10-23 18:51 Zapper Note Added: 0003985
2015-10-23 18:51 Zapper Relationship added related to 0001364
2015-10-23 21:21 Sven2 Note Added: 0003988
2015-10-23 21:22 Sven2 Note Edited: 0003988 View Revisions
2015-10-23 21:30 Zapper Note Added: 0003989
2015-10-23 22:10 Sven2 Note Added: 0003992
2015-10-24 19:43 Zapper Note Added: 0004001
2015-10-24 19:53 Sven2 Note Added: 0004002
2015-10-24 19:53 Sven2 Note Edited: 0004002 View Revisions
2015-10-25 00:02 Zapper Note Added: 0004005
2015-10-25 01:20 Sven2 Note Added: 0004007
2015-10-25 16:07 Zapper Note Added: 0004011
2015-10-26 13:27 Clonkonaut Status new => acknowledged
2015-10-26 13:55 Clonkonaut Relationship added related to 0001434
2015-10-26 13:57 Clonkonaut Note Added: 0004014
2016-01-10 14:19 Maikel Note Added: 0004517
2016-01-10 14:19 Maikel Status acknowledged => resolved
2016-01-10 14:19 Maikel Fixed in Version => 7.0
2016-01-10 14:19 Maikel Resolution open => fixed
2016-01-10 14:19 Maikel Assigned To => Maikel
2016-08-19 11:38 Newton Note Added: 0005290
2016-08-19 11:38 Newton Status resolved => closed
+Issue History