Anonymous Login
2017-11-21 14:57 CET

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0001238OpenClonkEnginepublic2016-08-19 11:39
ReporterMaikel 
Assigned ToIsilkor 
PrioritynormalSeverityminorReproducibilityhave not tried
StatusclosedResolutionfixed 
Product Version 
Target Version7.0Fixed in Version7.0 
Summary0001238: Crash in Deep sea mining
DescriptionUnfortunately no working record, it desyncs.
Additional Information    

    6.0: Caught signal SIGSEGV (0x0000000000000017)
    ./openclonk[0x5ab8ce]
    ./openclonk[0x5b6dfd]
    /lib/x86_64-linux-gnu/libc.so.6(+0x36c30)[0x7fdf8e1a8c30]
    ./openclonk(_ZNK7C4Value11FnCnvObjectEv+0xa)[0x8a0e1a]
    ./openclonk(_ZNK9C4AulFunc13CheckParTypesEPK7C4Value+0x184)[0x879644]
    ./openclonk(_ZN9C4AulExec4CallEP9C4AulFuncP7C4ValueS3_P10C4PropList+0x9e)[0x871b4e]
    ./openclonk(_ZN9C4AulExec4ExecEP8C4AulBCCb+0xa81)[0x872c11]
    ./openclonk(_ZN9C4AulExec4ExecEP15C4AulScriptFuncP10C4PropListP7C4Valueb+0x33a)[0x876d6a]
    ./openclonk(_ZN15C4AulScriptFunc4ExecEP10C4PropListP7C4Valueb+0x4b)[0x876f8b]
    ./openclonk(_ZN8C4Effect8DoDamageEP8C4ObjectRiii+0x645)[0x641a25]
    ./openclonk(_ZN8C4Object8DoEnergyEibii+0x962)[0x81b142]
    ./openclonk(_ZN13C4GameObjects10CrossCheckEv+0xc66)[0x7f34a6]
    ./openclonk(_ZN6C4Game11ExecObjectsEv+0xbc)[0x628efc]
    ./openclonk(_ZN6C4Game7ExecuteEv+0xad)[0x62e66d]
    ./openclonk(_ZN13C4Application8GameTickEv+0x21a)[0x62505a]
    ./openclonk(_ZN22C4ApplicationGameTimer7ExecuteEiP6pollfd+0xaf)[0x6251af]
    ./openclonk(_ZN12StdScheduler15DoScheduleProcsEi+0x2d2)[0x8c7172]
    ./openclonk(_ZN12StdScheduler13ScheduleProcsEi+0x124)[0x8c63d4]
    ./openclonk(_ZN13C4AbstractApp3RunEv+0x1d)[0x84fa5d]
    ./openclonk(main+0x100)[0x5ade20]
    /lib/x86_64-linux-gnu/libc.so.6(__libc_start_main+0xf5)[0x7fdf8e193ec5]
    ./openclonk[0x5b6cfd]

TagsNo tags attached.
Attached Files

-Relationships
has duplicate 0001452closedIsilkor Crash at the start of Deep Sea Mining 
+Relationships

-Notes

~0003418

Sven2 (developer)

Last edited: 2015-01-15 10:32

View 3 revisions

This looks like a deleted or enumerated C4PropList pointer in a C4Value. Maybe related to section changes. In that case, the sync loss of the record may be caused by the same issue.

Can you attach the record file?

~0003419

Maikel (developer)

It is there.

~0003428

Sven2 (developer)

I get sync losses starting from frame 9000:

FATAL ERROR: Network: Synchronization loss!
FATAL ERROR: Network: Rec Frm 9000 Ctrl 3000 Rnc 246716 Cpx 359726 PXS 10 MMi 0 Obc 476 Oei 12830 Sct 882
FATAL ERROR: Network: Client Frm 9000 Ctrl 3000 Rnc 246678 Cpx 359718 PXS 10 MMi 0 Obc 476 Oei 12830 Sct 882

Do you have the same?

~0004217

Isilkor (developer)

Fixed in 6738ef1.

~0005327

Newton (administrator)

Archiving old resolved bugs
+Notes

-Issue History
Date Modified Username Field Change
2015-01-14 22:50 Maikel New Issue
2015-01-15 10:32 Sven2 Note Added: 0003418
2015-01-15 10:32 Sven2 Note Edited: 0003418 View Revisions
2015-01-15 10:32 Sven2 Note Edited: 0003418 View Revisions
2015-01-15 10:51 Maikel File Added: 110-DeepSeaMining.ocs.tar.gz
2015-01-15 10:51 Maikel Note Added: 0003419
2015-01-17 00:59 Sven2 Note Added: 0003428
2015-10-16 02:33 Sven2 Target Version => 7.0
2015-12-01 11:56 Clonkonaut Relationship added has duplicate 0001452
2015-12-01 11:57 Clonkonaut Status new => confirmed
2015-12-01 23:41 Isilkor Status confirmed => assigned
2015-12-01 23:41 Isilkor Assigned To => Isilkor
2015-12-01 23:47 Isilkor Note Added: 0004217
2015-12-01 23:47 Isilkor Status assigned => resolved
2015-12-01 23:47 Isilkor Fixed in Version => 7.0
2015-12-01 23:47 Isilkor Resolution open => fixed
2016-08-19 11:39 Newton Note Added: 0005327
2016-08-19 11:39 Newton Status resolved => closed
+Issue History