Anonymous Login
2017-11-21 15:01 CET

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0001224OpenClonkObjectspublic2016-08-19 11:45
ReporterSven2 
Assigned ToClonkonaut 
PrioritynormalSeverityminorReproducibilityhave not tried
StatusclosedResolutionfixed 
Product Version 
Target Version7.0Fixed in Version 
Summary0001224: "Release Clonk" in treasure hunt (and other missions)
DescriptionYou can easily get stuck in missions and tutorials. There should be an accessible way to kill your own clonk.

Since we always forget about these rules, maybe add something to kill your clonk by default to all scenarios?

The only scenario where I think suicide is problematic is Maze, but even there we should solve it with delayed respawn rather than not allowing suicide (because you can easily get stuck in Maze).

The method to respawn (by rule menu?) should also be explained in tutorials somehow. Or in a "did you know?" section that is displayed during scenario load time.
TagsNo tags attached.
Attached Files

-Relationships
+Relationships

-Notes

~0004306

Clonkonaut (developer)

I started editing the missions. What about Deep Sea Mining? You have two clonks there, should you be able to restart which each one individually or only if you're down to one?

~0004307

Sven2 (developer)

Your call. You could also reduce it to one clonk. I think two clonks are nice for long distance works (like one clonk throws stuff into the ocean and the other catches it), but the mission is for newbies and they tend to not use two clonks anyway.

~0004308

Clonkonaut (developer)

I added this to all the missions for now. Reworked Deep Sea Mining to one clonk.

I didn't touch any scenario where you have more than one clonk or can buy clonks though.
+Notes

-Issue History
Date Modified Username Field Change
2015-01-11 00:09 Sven2 New Issue
2015-10-16 02:33 Sven2 Target Version => 7.0
2015-12-10 11:20 Clonkonaut Note Added: 0004306
2015-12-10 11:20 Clonkonaut Assigned To => Clonkonaut
2015-12-10 11:20 Clonkonaut Status new => feedback
2015-12-10 17:29 Sven2 Note Added: 0004307
2015-12-10 17:29 Sven2 Status feedback => assigned
2015-12-10 23:41 Clonkonaut Note Added: 0004308
2015-12-10 23:41 Clonkonaut Status assigned => resolved
2015-12-10 23:41 Clonkonaut Resolution open => fixed
2016-08-19 11:45 Newton Status resolved => closed
+Issue History