Anonymous Login
2017-11-21 14:59 CET

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0001170OpenClonkEngine - Controlspublic2016-08-19 11:38
ReporterIsilkor 
Assigned ToSven2 
PrioritynormalSeverityminorReproducibilityhave not tried
StatusclosedResolutionfixed 
PlatformLinuxOSDebianOS Versionunstable
Product Version 
Target Version7.0Fixed in Version7.0 
Summary0001170: Binding space bar to a control does not disable the default binding
DescriptionReport from IRC:
17:42 < nyancats> hello
17:43 < nyancats> I've installed openclonk Version: 5.5.1-2 as packaged currently in debian unstable, and I think
                  I have found a bug
17:44 < nyancats> after rebinding spacebar to jump in controls config, spacebar does work for jumping but also
                  activates the default function (interact)
17:44 < nyancats> I don't think this is supposed to happen.
TagsNo tags attached.
Attached Files

-Relationships
+Relationships

-Notes

~0003163

Isilkor (developer)

18:03 < nyancats> there is no conflict
18:04 < nyancats> the space was by default bound to something (interact I think)
18:04 < nyancats> I've changed that binding too
18:04 < nyancats> it's just that space continues to interact
18:04 < nyancats> disregarding the change

~0004029

Clonkonaut (developer)

This isn't limited to space. Assigning any key to something doesn't unassign it from its current assignment.

~0004508

Sven2 (developer)

Assigning the same key to multiple bindings is intended because you may want to allow overloads. For example you can have space on Interact and Jump and then jump only if interact was not possible. But there could be a warning.

~0004509

Sven2 (developer)

I added a warning. Note that we do use duplicate assignments e.g. for MenuOK and Interact.

~0005291

Newton (administrator)

arhiving old resolved bugs
+Notes

-Issue History
Date Modified Username Field Change
2014-10-27 18:00 Isilkor New Issue
2014-10-27 18:05 Isilkor Note Added: 0003163
2015-10-16 02:33 Sven2 Target Version => 7.0
2015-10-26 15:27 Clonkonaut Note Added: 0004029
2015-10-26 15:27 Clonkonaut Status new => confirmed
2016-01-09 21:37 Sven2 Note Added: 0004508
2016-01-09 22:00 Sven2 Note Added: 0004509
2016-01-09 22:00 Sven2 Status confirmed => resolved
2016-01-09 22:00 Sven2 Fixed in Version => 7.0
2016-01-09 22:00 Sven2 Resolution open => fixed
2016-01-09 22:00 Sven2 Assigned To => Sven2
2016-08-19 11:38 Newton Note Added: 0005291
2016-08-19 11:38 Newton Status resolved => closed
+Issue History